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What kinds of support are available for my Solar products?

Issue:
Customer is looking for support on a Schneider Electric Solar product.

Product Line:
Conext Inverters (XW+, XW, SW, GT, TX, XC, GT 3ph), Conext Accessories, Solar products

Environment:
Any Schneider Electric Solar solution.

Cause:
Customer has experienced an issue or has a question on a Solar product.

Resolution:
  1. What hours are the phone support lines open?
    • Monday - Friday -- 6:30 AM - 4:30 PM Pacific

  2. What if my Solar product says Xantrex on the cover?
    • All Xantrex products that were certified for residential or commercial use are supported (products for the mobile market are still supported by Xantrex).

  3. Where are my shipping labels for my warranty replacement unit?
    • Shipping labels are approved on a case by case basis.

  4. What support is offered for 3rd party products that directly attach to a Solar product (i.e. - Midnite Solar E-panel).
    • We are unable to provide support for products that are not part of the Schneider Electric portfolio.

  5. Where can I request additional training on Schneider Electric products?
    • Please call 1-888-778-2733 and use option #3.

  6. Where can I find product documenation or general product information?

  7. Who can service or repair my Solar product?
    • Please call for assistance in locating the nearest Authorized Service Center (ASC) for your product.

  8. Where can I find pricing or availability for a Solar product?

  9. How can I provide feedback on Solar products or submit a feature request?
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