Technical FAQs

Ask a Question

Who do I contact for support with the Drives and Soft Starts start-up program?

Issue:
Who do I contact for support with the Drives and Soft Starts start-up program?

Product Line:
All Altivar drives and soft starts, open style and/or enclosed.

Environment:
Drives start-up website : http://drivestartup.schneider-electric.us/#/home

Cause:
Customer is having problems registering drive products or is not authorized to register a drive product and is looking for training, or general assistance with the website or drives start-up program.

Resolution:
After registering an account on the drives start-up website, you can select "Program Support" in the left hand pane from the home page to send an E-mail request directly to the program management team for the drives Start-up certification program.   All requests for training, assistance, or bug reports for the website should be sent to the management team in this manner.
Was this helpful?
What can we do to improve the information ?