Technical FAQs

Ask a Question

How do I troubleshoot an Altivar Process Drive that would not connect to a CanOpen network?

Issue:
How do I troubleshoot an Altivar Process Drive that would not connect to a CanOpen network?

Product Line:
Altivar Process Drive (ATV630, ATV930, ATV650, ATV950, ATV660, ATV960, ATV680, ATV980)

Environment:
All serial numbers for Altivar Process Drive

Cause:
N/A

Resolution:
Note: This FAQ goes over some basic checks and troubleshooting tips. For extended troubleshooting please refer to your drives CanOpen manual. 

Drive Will Not Connect
  • Card
  • Installation
    • Make sure card is installed in appropriate Slot. Should be using Slot A for all Process Drives
    • Pin Layout - Make sure to use proper pinouts for cables.
    • Isolate any electrical interference
      • Use conduits or other isolating material
      • Separate control and power connections
    • Terminating resistors must be placed on both ends of a CAN bus line. A 120 Ohms terminating resistor between CAN_L and CAN_H is used for this purpose.
  • Network
    • Check for any duplicate addresses on the network.
    • Check to make sure you have proper configured assemblies
    • Check LEDs on the drive
    • The following FAQ describes the LEDs status for Ethernet IP Field-bus for the Altivar Process Drives
  • Programming
    • Check Basic Settings on the drive. Make sure the following is set:
      • [CANopen Address​]
      • [CANopen Baudrate]
      • [CANopen Error]
​​Drive Connects But Will Not Run
  • Network​
  • Programming on the Drive
    • Confirm drive is setup for Network Control
    • Check Command and Reference Menu
    • [Complete settings] [Command and Reference]
  • ​​Troubleshooting
    • Check Communication Map
      • [Display] [Communication map]
      • Check Command Channel 
      • Command Register
      • Ref Freq Channel
      • Ref Freq
  • Reference attached manuals for further troubleshooting
Was this helpful?
What can we do to improve the information ?